Uploaded image for project: 'ONOS'
  1. ONOS
  2. ONOS-6010

PXE: Correct bugs reported by Bob

    XMLWordPrintable

    Details

      Description

      0. Test setup

      I tested it manually, on VMware fusion (8.5.3) with a bridged>autodetect network adapter, running on macOS 10.12.3, on my laptop, connected to the onlab wi-fi network.

      1. It takes a long time to start up - after I hit return it hangs for a long time. No network activity is observed.

      2. Eventually it started up, but DHCP configuration failed.

      In general, I notice that DHCP doesn't seem to be working particularly well with the bridged interface. Sometimes when I would restart the VM, the DHCP phase of PXE booting would fail.

      3. I retried DHCP configuration and it worked.

      4. The installation proceeded as expected for a while.

      5. The installation halted with a "Partition disks" dialog and a "write changes to disk?" question:

      6. I hit <Yes> manually, and it continued.

      7. Eventually it rebooted.

      8. I was able to log in with the user name/password you gave me, but that should probably be documented.

      9. There were Applications and Downloads directories.

      10. Java 8 was installed as expected.

      11. git wasn't installed, and the ONOS source tree was missing; Mininet was also not installed.

        Attachments

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            Assignee:
            luca Luca Prete
            Reporter:
            luca Luca Prete
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: