Uploaded image for project: 'ONOS'
  1. ONOS
  2. ONOS-7405

After restarting nodes, intents sometimes don't get recompiled on link downs

    XMLWordPrintable

    Details

    • Story Points:
      5
    • Epic Link:
    • Sprint:
      N Sprint #3 - Platform & ISSU

      Description

      • Install 10 host to host intents, all with same route except the end devices
      • Run some tests( pings, dist-primitives, etc)
      • Stop 2 of 7 nodes (nodes 1 and 5)
      • run some tests
      • restart the 2 nodes
      • run some tests
      • Bring down link between s3 and s28
      • Most intents reroute
        • all nodes see the link/topo events and trigger the recompile, but some nodes say they have no intents assigned/affected( this may be true for some work partitions, but somewhere the intents aren't getting tracked).
        • All intents say they are INSTALLED
        • The intents that did not recompile still have the same old flows installed (Looks like switches don't complain if the input/output ports are down)
      • When bringing the link back up, we can again ping across all intents
      • All intents work when Taking down a node after this

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              Assignee:
              tom Thomas Vachuska
              Reporter:
              jhall Jon Hall
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: